Solved: Beginning of IVR Message Cut off

Problem: When calling an inbound line, the first part of the message is chopped off.

Answer: When using IVR’s in FreePBX, cutoff messages rarely happen, because it configures the dialplan to leave a bit of silence at the beginning of the message.

Now, if you aren’t using FreePBX, or if you happen to use an external service like, which hosts a [800] number for you and then redirects it wherever you want. Well those services are phone systems, too, most likely asterisk based, and here is where configuration can get tricky. Basically, the 3rd party waits until the [your asterisk box] system answers, and then starts playing, this can chop off a few seconds.

Worse, if you call the IVR directly, you may hear the message perfectly, and you don’t want regular callers to hear unneeded silence.

Let’s solve the first problem first:

This can be fixed easily by editing the asterisk configuration file: extensions_custom.conf
Make sure you have the DID (phone number) of the line, and add this:

exten => 9495556992,1,Answer()
same => n,Wait(2)
same => n,Goto(ivr-1,s,1) ;this should be the name of your original IVR
same => n,Hangup

If you don’t know the name of the original ivr, just open /etc/asterisk/extensions_additional.conf and search for your phone number.

If you have the 2nd issue, you will want this similar code:

exten => 9495556992/18005551234,1,Answer()
same => n,Wait(2)
same => n,Goto(ivr-1,s,1)
same => n,Hangup

Notice that we did /1800xxx this time, this is because we set up the 3rd party service to send our 800 number as the callerid, and we are filtering by caller id, so asterisk knows if the call originates from that line, it will run our new dialplan, which just waits for 2 seconds then forwards it along to the original message 🙂

Tagged with: , , , ,
Posted in Tips n Tricks, Troubleshooting

Leave a Reply

Your email address will not be published. Required fields are marked *